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ABAQUS Tutorial

3D Modeling

This exercise intends to demonstrate the steps you would follow in creating and analyzing a

simple solid model using ABAQUS CAE.
Introduction

A solid undergoes thermal expansion due to the application of heat along with deformation due to

applied load.
Model Definition

Consider a thin aluminum cylinder of length 1 m and inner and outer radii 0.2 m & 0.21 m respectively.
The cylinder is kept fixed at one end and at the other end a tensile load of 200 kPa is applied. The fixed
end of the cylinder is at 273.15 K (the ambient temperature) and the free end at 274.15 K (all other sides

are insulated). The cylinder expands due to the heat flow.

The various functions within ABAQUS are organized into modules and we are going to use these

modules to define the steps in our procedure.

>module load abaqus/6.9-2
>abaqus cae

Once you start ABAQUS CAE select Create Model Database to create a new model.

A

The default module that opens up is the Part Module.



Part Module:

This module allows you to create the geometry required for the problem. To create a 3-D

geometry you first create a 2-D profile and then manipulate it to obtain the solid geometry.

1. From the Part Toolbox on the left of the viewport select Create Part.

2. You can name the part as cylinder or anything else you like. We are going to create a
deformable solid shape in the 3-D modeling space through extrusion so we do not
change the default selections.

3. Enter 1 as the approximate size and click Continue.

|"-- Create Part

Mame: |cy|inde{

— Modeling Space

& 30 ¢ zD Planar O Axisymmetric

— Type Of
& Deformable
& Discrete rigid

. - MNone availahble

© Analytical rigid

& Eulerian

— Base Feature

Shape Type
& Solid
¢ shall Revaolution
Swee
& Wire P
& Point
Approzimate size: |1

Continue... I Cancel |




4. Click Create Circle Center and Perimeter on the drawing toolbox and enter 0, 0 as the
center point in field below the viewport and press Enter. Enter the perimeter point as
0.21, 0 and press Enter to complete the circle. Similarly make another circle with the
same center and the perimeter point as 0.2, 0. Press Esc to exit the circle definition and

then press Done.
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5. Enter the extrusion depth as 1 and press OK.

L Edit Base Extrusion

— End Condition
Type: Blind

Diepth: I‘II

— Options

Hote: Twist and draft cannot be specified together.

[T Include twist, pitch: ID (iR e

[T Include draft, angle: ID (Egrees)
Cahcel |

6. Click Auto-Fit View in the toolbar above to zoom out and view all the points.
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This finishes our work in the Part module. Select Module: Property from the toolbar above the

viewport.
Property Module:

In this module you define the material properties for your analysis and assign those properties

to the available parts.

1. Select Create Material from the Property Toolbox.

2. Enter material name as Aluminum. Click on the General tab and select Density from the
drop-down menu. Type in the mass density as 2700. Click on the Mechanical tab and
select Elasticity>Elastic from the drop-down menu. Enter the Young’s Modulus as 70E9
and the Poisson’s Ratio as 0.33. Click on the Mechanical tab and select Expansion. Edit

the reference temperature to 273.15 and the expansion coefficient to 23e-6. Click on



the Thermal tab and select Conductivity. Enter the thermal conductivity as 160. Click on

the Thermal tab and select Specific Heat. Enter the value as 900 and click OK.

Edit Material x Edit Material

Aluminum Aluminum

Edit Material @ Edit Material x




3. Select Create Section from the property toolbox. Name the section as you like. We need

a solid homogeneous section for our problem. Click Continue. Select the material as

Aluminum and click OK.

C Edit Material x

Name-lAIummum
Description:

g Edit...
General  Mechanical | Thermal Other Delete
. uiu T Conductivity

nductiity Heat Generation
Type: |Isofropic | Inelastic Heat Fraction
I™ Use temperature-qepe  <0UI8 Heat Fraction
R, ” Latent Heat

e o ) e o
[~ Data

[[] conductivity

I

Ok Cancel

Create Section

Marme: |P.Iuminum_hnni

Category, [ Type
& Solid

" Shell Generalized plane strain
C Beam Euleriatnlt

omposite
O Cther F

Continue... I

Cancel |

Mame: Aluminum_tam
Type: Solid, Homogeneous

hdaterial: |.-'-‘-.Iuminum

™ Plane stressistrain thickness: |1
Ok, | Cancel |

Click Assign Section on the property toolbox and select the part from the viewport. Click

Done below. Select the section you had created and click OK.
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|'-- Edit Section Assignment

— Section

Section: I.-‘-‘«Iuminum_hum

Mote: List contains only sections
applicable to the selected regions.

Type: Solid, Homogeneous

kdaterial: Aluminum

— Region
Region: (Picked)

Ok | Cancel |




Our work in the Property module is done and we select the Assembly Module from the toolbar

above the viewport.
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This module allows you to assemble together parts that you have created. Even if you have a

single part you need to include it in your assembly.

1. Select Instance Part from the Assembly Toolbox.

2. Select the part you have created from the parts list and then select Instance type:

Independent. Click OK.



Create Instance

— Instance Type
" Dependent (mesh on part)

& Independent (mesh on instance);

Mote: To change a Dependent instance's
mesh, you must edit its part's mesh.

[T auto-offset from other instances

Ok I Spply Cancel

Select Module: Step from the toolbar above.
Step Module:

This module allows you to select the kind of analysis you want to perform on your model and
define the parameters associated with it. You can also select which variables you want to
included in the output files in this modules. You apply loads over a step. To apply a sequence of

loads create several steps and define the loads for each of them.

1. Select Create Step from the Step Toolbox.
2. Name the step as you want and select Coupled temp-displacement as the procedure.

Click Continue.

Narme: |Step-1

Insert new step after

IGeneraI VI

Procedure type:

Coupled thermal-electric

Dynamic, Implicit

Dynamic, Explicit

Dynamic, Temp-disp, Explicit
Geostatic

Heat transfer

tass diffusion d|

Continue... Cancel |




3. The edit step dialog box lets you choose the solution technique, the solver type and
define the time stepping strategy.

4. Under Basic change the Response to Steady-state and click OK.

' Edit Step x|
Mame: Step-1
Type: Coupled temp-displacement

Incrementatian | Other'

Description:|

Response: © Steady-state ¢ Transient

Time period: |1

@ of {This sefting contrals the inclusion of nanlinear effects

i ¢ op Oflarge displacements and affects subsequent steps.)

Automatic stahilization: |N|:une j

[ Include creepfswellingdviscoelastic hehavior

Cancel |

The Interaction Module allows you to set up interactions (contact, film), constraints,
connectors, fasteners and wire feature between parts. Our problem does not involve any of
these features but it will be a good idea to explore this module on your own at a later time.

Select Module: Load from the toolbar above.
Load Module:

The Load Module is where you define the loads and boundary conditions for your model for a
particular step (indicated in the toolbar above). You can even define loads and boundary

conditions as fields like electric potential, acoustic pressure, etc.

1. Select Create Load from the Load Toolbox. Select Surface Traction and click Continue.

Select the top face of the cylinder (z=1) (it gets highlighted in red) and click Done.



'-- Create Load

Mame: ILUad—‘I

Step: [Step-1 hd i
Procedure: Coupled temp-displacement
— Category —— | Types for Selected Step

' Mechanical Concentrated force &

" Thermal rament

! Araustic Pressure

Shell edge load

£ Fluid
! Eleciical ipe pressure
1 Iyl 2se diffusion Eody force
" Otfier Line load
Gravity
Bolt load =l

Continue... | Cancel |

2. Change the Traction type to General. Click on the Edit tab under Direction in the dialog

e e | ] 2

box. Enter the starting point of the direction vector as (0, 0, 0) and the end point as (0,0,

1). Enter the Magnitude as 2e5 and click OK.

Edit Load
Mame: Load-1
Type:  Surface traction
Step: Step-1 (Coupled temp-displacement)
Region: (Picked)

Distribution: IUniform VI Create...l
Traction: IGeneraI VI

Direction

Vector: (0,0,1) Edit.

CEYa: IGIDbaI Vl

ragnitude: IZeq
Amplitude: | (Ramp) hd Create...l

Traction is defined per unitldeformed area VI

IV Fallow ratation

Ok | Cancel |

3. Select Create Boundary Condition from the Load Toolbox. Select Ssymmetry /

Antisymmetry / Encastre and click Continue. Select the bottom face (z=0) of the

cylinder and click Done. Select Pinned (U1=0, U2=0, U3=0) and click OK.



Procedure: Coupled temp-displacement

& Mechanical | | B8

Connector velocity

— Category — | Types for Selected Step

 Other Displacement/Rotation
Welocity/angular velocity
Connectar displacement

Cancel |
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Edit Boundary Condition

MName: BC-1

Type:  Symmetry/antisymmetry/Encastre

Step: Step-1 (Coupled temp-displacement)
Region: (Picked)

ole Nia e e e e

-

HSYMM (U1 = URE = UR3 = 0)
YEYMM (UZ = UR1 = URG = 0)
ZSY MM (U3 = URT = URZ = 0)
HASYMM (U2 = U3 = URT = 0; Ahagus/Standard anly)
YASYMM (U1 = U3 = URE = 0; Abagus/Standard only)
ZASYMM (U1 = U2 = UR3 = 0; Ahagus/Standard anly)

PIMMED {1 = Uz = U3 = 0y

EMCASTRE (U1 = U2 = U3 = UR1 = URZ = URG = 0}

Ok | Cancel |

4. Again select Create Boundary Condition from the Load Toolbox. Switch Category to

=

Other and select Temperature and click Continue. Select the bottom face of the cylinder

and press Done. Enter the magnitude as 273.15 and click OK. Similarly put the top face

at 274.15.

|"-- Create Boundary Condition

Mame: [BC-2

Step: [step1 ¥

Frocedure: Coupled temp-displacement

— Category — | Types for Selected Step
C Mechanical || Qe

* d Connector material fow
Submodel

e —




Edit Boundary Condition

Mame: BC-2

Type:  Temperature

Step:  Step-1 (Coupled temp-displacement)
Region: (Picked)

Distribution: IUnifDrm j Create...l

Magnitude: {27319

amplitude: I(Ramp) j Create...l
Ok | Cancell

Edit Boundary Condition
Mame: BC-3
Type:  Temperature
Step: Step-1 (Coupled temp-displacement)
Region: (Picked)

Distributian: |Unif|:|rm j Create...l

Magnitue: |274.15

Amplitude: |(F~!amp) j Create...l
Ok | Canu:ell
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Now that we have defined the loads and the boundary conditions we move on to mesh the

geometry. Select Module: Mesh from the toolbar above the viewport.
Mesh Module:
The mesh model controls how you mesh your model — the type of element, their size etc.

1. Select Seed Part Instance from the mesh toolbox. Enter the approximate global size as

0.025.



Global Seeds

Appromate ghobal size: [0025
F Curvahure control

Mainaim deviston factor (0.0 < b < 1.0) 07
(Agprosimats rumber of slaments par circle ©)

Mirimum si28 factor (33 @ fraction of Giobal sizs).
@ Use defaut (0.1)  Specty 00 <min<1.0)[a1

ok | [Thewy]  owes| _concel |

L] X] ot 0 cata wsing the Giooal Sueds dialog 7z

2. Click on Mesh Part Instance and then on Yes to mesh the model.

Module; [Mesh madsl [Voos1 3], Object & Assembly C Part [ ]
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Module: [Mesh ~] Model:[Model-1 ] Object: & Assembly C Part; 5]
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Simuia

3. Select Assign Element Type from the mesh toolbox. Under Family select Coupled

Temperature-Displacement and switch Geometric Order to Quadratic. Click OK.

- Element Type x
Element Library Family
& Standard C Explicit || [Continuum Shell =
Coupled Temperature-Displacement
Geometric Order Gaskel o
’1‘ Linear & gmm Heat Transfer &

Hex | wedge | Tet|
Element Controls
I~ Hyhrid farmulation

¥ Reduced integration

Viscosity @ Use deraut © specity [
Element delstion: & Use default ¢ Yes ¢ No
Max Degradation: & Use default O Specity [

C3D20RT: & 20-node thermally coupled brick, triquadratic displacement, tiinear temperature, reduced integrafion

Note: To select an element shape for meshing,
select "Mesh->Controls” fram the main menu bar

K Defaults Cancel




When finished select Module: Job from the toolbar above.
Job Module:
This module allows you to submit your model for analysis.

1. Select Create Job from the Job Toolbox. Name the job as you like. Select your model
and click Continue.

o Create Job X

Vooe S

hodel-1

2. You can add a description to the job, allocate memory, allot multiple processors and

select precision. Use the default values and click OK.

Edit Job

3. Select the Job Manager from the toolbox and click on the Write Input tab.



5 Job Manager x|

Mame Model Type Status

cylinder rodel-1

Data Check
Submit
L0 ] ] =
kanitar...

Results

[t Clat]
T
[ oninz
[ b |
T
[

il

Create...l Edit... | Copy.. | Hename...l Delete.. | Dismiss |

If you are running the job for the first time it is advisable to run Data Check to check the

input file for errors. Click OK to overwrite the job files.

] Job Manager (x|
Name Model Type Status Write Input |
cylinder MModel-1 is Mone Data ChECkl

Submit |
/y, dob files already exist for cylinder. e |
L= O to ovenytite? Monitar |
¥ Show this warning newxt time
Results |
Cancel | Kill |
Create... | Edit... | Copy... | Hename...l Delete... | Dismiss |

Once the data check is completed Submit the job for analysis. Click OK to overwrite the
job files. You can click Monitor to observe the progress of the solution process. You can

see the errors, warnings, data and message file.

= cylinder Monitor x

Job: eylinder  Status: Completed

Severe i

. Equil Total Total Step Time/LPF
gy || Ceemzie || G D'f'”’“ lter fter | TimefFreq | Time/LPF Inc
1 1 1 0 1 1 1 1 1

I Etrars | I Warnings | Outputl Data File | Message File | Status File

ubmitted: Wed Feb 9 14:41:33 2011

Started:  Analysis Input File Pracessor
Completed: Analysis Input File Processor
Started:  Abaqus/Standard

Completed: Abagus/Standard

Completed: Wed Feb 3 14:42:12 2011

Search Text
’irextm find: | " Match case Il Mext {p Previous

il Dismiss




6. Once the job is completed click on the Results tab on the job manager. This opens the

Visualization Module for postprocessing.

Visualization Module:

This model allows you to look at your model after deformation. You can also plot values of
stress, displacement, reaction forces, etc. as contours on your model surface or as vectors

or tensors.

1. Select Plot Deformed Shape from the Visualization toolbox.

Mocule: | =] oos: [rom PE| Wea pow|F

QDB cylinder.odb  ARagusiStandard 6.9-2  iWed Feb 09 14:41:45 EST 2011

Step: Step-1

Y p
Increment — 1: Step Time = 1000
)\ Deformed var: U Deformati oale Factor: LM568e+01
z %

2. Select Plot Contours on Deformed Shape to plot stress contours on the model

surface.
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©DB: cylinder.odb  Abaqus/Standard 6.9-2  #ed Feb 09 14:41:45 EST 2011

Step: Step-1

Increment
mary Var: S, Mise:
eformed Var: U Deformation Scale Factor: 4

me = 1.000

S,

3. You can see the location of the maximum & minimum stresses by selecting Contour

Options>Limits>Show Location.

|'-- Contour Plot Options

Basic | Calor & Style  Limits | Gther |

HMote: User-defined interval values override
the seftings below.

 Minfidax
Max & Auto-compute (8.78462e+08) W Show location

" Specify: IB_?B462E+DB

Min: & Auto-compute (26033.1) W
 Specify: [26033.1

— Auto-Computed Limits
When auto-computing animation limits:
Use first and last frame limits j

[o];8 Apply Defaults Cancel
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4. Select Results>Field Output from the main menu. This opens a dialog box that
allows you to select the variable you want to plot in the viewport.
5. Select U (Spatial Displacement at nodes)>Magnitude>OK to plot the displacement

contours on the model.
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6. To plot displacement vectors click on Plot Symbols on Deformed Shape on the

toolbox.

=] oos 25 | WA b s B0
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7. You can now animate this plot by selecting Animate Harmonic.

Mouse Gestures:

Ctrl+Alt+Left Click (MB1): Rotate View
Ctrl+Alt+Middle Click (MB2): Pan View
Ctrl+Alt+Right Click (MB3): Magnify View
Use Shift key to select multiple objects.

Note on System of Units:

ABAQUS has no built-in system of units. Specify all unit data in consistent units. Some common
systems of consistent units:

Sl: m, N, kg, s, Pa, J, kg/m>

SI (mm): mm, N, tonne (1000 kg), s, MPa, mJ, tonne/mm?

US Unit (ft): ft, Ibf, slug, s, Ibf/ft?, ft Ibf, slug/ft>

Questions, comments? Contact: beatnic@aset.psu.edu



